jump to navigation

IBM Websphere Portal is Web 0.5 February 26, 2008

Posted by Tomas in IBM Webspehere.
Tags:
trackback

One of the selling Websphere Portal features is the integrated MVC framework – Struts. Websphere Portal uses modified Struts 1.1 Framework. Not only modifications are buggy, but it is ancient! Struts 1.1 was released on 29th of June 2003. This is Web 0.5 technology, the rest of the world have moved on but Websphere portal stayed behind.

No to mention that Webshpere portal runs on modified (why would you do that?) 1.4 jdk. This complicates things a lot. No modern tools can be used for development or troubleshooting. We tried to profile the slowness using Netbeans and struggled. Old JDK version would not allow us to use native java debugging capabilities and modified JVM crashes because of class versioning.

So if you can use tomcat or something based on it and stay away form Websphere Portal.

About these ads

Comments»

1. Angry in Atlanta - March 13, 2008

I have been forced to develop on websphere portal as well for the last 6 months. I was temporarily assigned to a project 2 weeks ago, where I developed with a real tool. Today, I had to come back to portal. It sucks. I feel like putting a gun in my mouth.


Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

Follow

Get every new post delivered to your Inbox.

%d bloggers like this: